Bongiovi DPS

Yosemite DP4 breaks DPS

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #64572
    Perplexity
    Participant

    I just updated to DP4 and DPS is broken now. It did run in DP3, but now gives the following error: Couldn’t fetch the Digital Power station device. Please reboot to resolve the issue. Rebooting does not fix the issue!

    #64584
    Perplexity
    Participant

    I installed some other sound tools to get my DPS-quality music back.

    Boom didn’t install too, so something clearly changed in the audio output with DP4. I tried Hear too, but that tool makes music worse, the default presets give lots of distortion! (ouch) So I think I have 2 options: wait for a fix or install Mavericks again.

    Let’s install Mavericks again. Wait, I can’t download Mavericks from the App Store because it requires Snow Leopard, Lion or Mountain Lion! Ouch again! I guess the only thing I can do is start up from the recovery partition and do a clean install. Install all my software again? No way…

    So, I’m waiting for a fix lol. It’s in times like this that you realize how good DPS is…

    #64583
    raleighing
    Participant

    I installed the Yosemite Public Beta yesterday and it DPS is now broken for me too.

    #64582
    xaqmusic
    Keymaster

    so it seems the latest build of Yosemite requires a change in how kexts (like our audio driver) are signed for security.  this *should not be a difficult fix. i will let  you know our progress as we chase this one down.

    #64581
    Dan Rice
    Keymaster

    Regarding the reported Yosemite beta/DPS plugin compatibility problem.  We have a workaround.  Please use this at your own risk, for testing purposes only.  I am unsure what system security implications this workaround may present to your system.

    In terminal, paste:

    sudo nvram boot-args=”kext-dev-mode=1″

    DPS should work.  This method disables Apple’s new app (kernal extension) signing requirement.  It is unclear whether this requirement will make it to the final release of Yosemite.

    #64580
    Perplexity
    Participant

    I tried your sudo command and it didn’t work. So, I removed the “” and it worked! 🙂

    sudo nvram boot-args=kext-dev-mode=1

    Thanks for your tip! How do we revert back to normal? mode=2?

    #64579
    Dan Rice
    Keymaster

    It seems odd that you had to leave out the quotes.  From what I’m reading, it seems those quotes are pretty important.  Glad it worked for you!

    To revert to default, and to  have the system boot normally without any extra options try:

    sudo nvram boot-args=””

    or

    sudo nvram -d boot-args

    #64578
    xaqmusic
    Keymaster

    Back to normal is probably mode=0.  That is standard for a default setting.

    #64577
    bnmguy
    Participant

    I can confirm that the command drice gave, (sudo nvram boot-args=”kext-dev-mode=1″ ) does indeed work. Just be sure to reboot after.

    Pasting this again without quotes will simply place an additional value in “nvram”,  that may, or may not do anything. You can see  the current value of nvram by typing:

    nvram -p

    in terminal.

    Unless you delete boot-args argument first before typing in the one without quotes, you’ll end up with two entries. If this happens,

    to be safe, run:

    sudo nvram -d boot-args

    and then re run the command that drice posted avbove.

    to revert, simply:

    sudo nvram -d boot-args

    to clear your boot time arguments.

    #64576
    xaqmusic
    Keymaster

    Thanks, bnmguy!

    We are working on getting the kext signed now.  It seems, yet again, there are some undocumented requirements for this no one is aware of.  I will keep you guys updated…

    #64575
    bnmguy
    Participant

    Thanks!

    I am consistently impressed with the Bonjiovi DPS team. Your interaction, and willingness to listen and take feedback from the community of DPS users has been phenomenal. Many “bigger” companies should take note! Keep up the great work!

    #64574
    avincent98122
    Participant

    Freaky Friday greetings. All good. I suspect the quote in the sudo cmd is the culprit, as deleting the quote is what caused DPS to load properly w/ the work-around. Of all the extras I miss for Yosemite incompatibility, DPS was tops on the list. Now .. Happy Friday!

    Namaste,
    Anthony

    #64573
    bnmguy
    Participant

    Seems to only be a problem if you are copying and pasting (at least, for me). Likely something to do with text encodings. If you type it in manually, it works.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.