Bongiovi DPS

Mavericks OSX Issue List

Viewing 15 posts - 16 through 30 (of 38 total)
  • Author
    Posts
  • #64623
    xaqmusic
    Keymaster

    Hi, everyone.

    I have a build for everyone to test (if you want to) that includes the latest changes we’ve made to support Mavericks.  As you all know, the issues are not easily repeatable on many systems so progress has been slow.  Here are the instructions:

    1. Uninstall the current version of DPS using Applications/Digital Power Station/Uninstaller.
    2. Reboot.  This will ensure the old driver is no longer running.
    3. Download and Install the 24bit test version:  Click Here to Download v1.0.4_24bit
    4. Reboot as per the installation instructions.
    5. Launch Applications/Utilities/Audio MIDI Settings.
    6. Open the Audio Devices window from the Window menu.
    7. Set all of the audio devices in the list to 24bit integer.  Be sure to click Input and Output tabs to be sure all routes are set to 24bit.

    Other hints:

    • Some Macs have stuttering audio with DPS while playing full screen video in iTunes.  While the video is playing, set the audio drivers to 24bit in Audio MIDI Settings.  This resets the drivers and can help eliminate choppy audio when you restore the video to full screen.
    • A new version of VLC media player has been released which has better performance with audio enhancers. See this forum post.
    #64622
    konkrypton
    Participant

    Initial testing says this version helps some issues. I was having the stutter issue with a Safari video (Vimeo player, it looked like) at http://howardcantour.com and this update stopped the stutter. The video sound stuttered and the player was not full screen.

    When using full screen video in iTunes, I still experienced some effects, more like someone putting their hand over the speaker repeatedly than the stuttering – the volume seemed to fluctuate. Opened Audio Midi Setup and it was set for 24 bit, so I set it back to 32bit and the effect stopped. Then set it back to 24 bit and the effect was still gone.

     

    #64621
    Joseph Beaty
    Keymaster

    Setting the bit rate at all seems to be what is helping. The number seems irrelevant. This setting process seems to be re-calibrating something. Something new. We are looking into this. As previously mentioned, We are working with Apple on a support ticket. Once we have some indication of what has changed with them since Mavericks/QuicktimeX, etc we can move ahead. The help our users are giving here is very much appreciated. Definitely keep sharing your findings. Thank you!

    #64620
    misterarthur
    Participant

    Hi. I just reinstalled DPS per your instructions.  The volume issue seems resolved – at least with iTunes. However, the menu bar icon is highlighted in blue. And stays highlighted. Then when you quit DPS, the icon disappears from the top ‘menu bar’.

     

    #64619
    konkrypton
    Participant

    I’ve found another oddity, which may be related. A podcast using the 5by5 player on this page has the same stuttering, so it must be connected to the video issue.

    #64618
    helixx2dbl
    Member

    I am not running any other audio plugins either.

    #64617
    hooger
    Participant

    Not to sound rude. Since the Mavericks update the DPS is not useable for me. It really bugs me.

    I tried the hotfix  from xaqmusic which did not help at all. Is there  any progress in sight or is everybody just involved in the 2.0? For me it seems so.

    I really like the DPS. But it is now 2.5 Months that I can not use it!!!

    #64616
    xaqmusic
    Keymaster

    Hi, guys.  Just so everyone is aware of our progress…

    1)  We still have a support ticket open with Apple’s driver support team.  The holidays have certainly slowed things down but we are in touch with them.  We need to speak with their driver support team directly because there are aspects of OSX Core Audio that have changed at the kernel level that affect all virtual audio drivers.  This includes the popular open source Soundflower internal audio routing software.

    2)  We have solved the 100% CPU usage issue.  This only presented itself to us when we were in Las Vegas at CES.  It is caused when DPS is activated on a network that requires a login (Airports, Hotels etc).  We will have a new build available shortly that fixes this issue.  It’s easy to fix a problem when you can replicate it 🙂

    We are responding as fast as possible when we get information about these issues.  Getting actionable info has been the main issue here.  I really appreciate everyone’s patience!

        

    #64615
    xaqmusic
    Keymaster

    Hey, folks.

    Here is a link to a new build that fixes the 100% CPU issue:  https://www.dropbox.com/s/xk1t5xtbrldc91k/Digital%20Power%20Station_1.0.4_HTTPCaching1.zip

    Be sure you have 1.0.4 installed as usual.  Replace the “Digital Power Station” application in  Applications/Digital Power Station/ with the above version.

    1.0.5 will be released soon and it will include this fix.  Still waiting on Apple for the kernel stuff though…

    #64614
    casj
    Member

    I can also confirm the issues misterarthur is having :

    Yesterday, after disconnecting from an external monitor (hooked up via HDMI), I went to iTunes to play a streaming radio station and the speakers were very low (I usually have it set on only 1-2 bars in the office) and just pushing out electronic tones/beeps. I normally keep DPS running, and it’s almost always using the output via the built-in speakers on my MacBook Pro 15″ Retina 2.7  GHz Intel Core i7 maxed at 16 GB memory. I used the keyboard volume keys, but they had no effect. Clicking on the DPS task bar icon also had no effect. I went to system settings, Audio, and switched from the DPS Reflector back to Internal Speakers – keyboard volume buttons worked fine – as did the taskbar and iTunes volume bars. Switched DPS back on, nope. I restarted the machine – still no effect – except that then the task bar icon turned blue (hover/click effect didn’t revert back to inactive state). I also saw the issues with the Preferences window as described in this thread – it was buggy switching between tabs, and stopped switching altogether.

    Just now, after waking the machine from sleep – the task bar wouldn’t even open, and after a few minutes, it opened, but now it’s blue again.

    The only things I can think of that I’ve done differently currently vs. in the recent past (when it worked flawlessly) are :

    I installed iWork ’09 and used Keynote, and modified video settings (but not audio)

    I installed “Display Menu” by Thorsten Karrer v. 1.4

    I had my WiFi “on” when visiting a local university, where, when I opened and woke my machine from sleep, it found a network I had used in the distant (several months ago) past, and automatically popped up a custom notification asking me to authenticate to use the network (which I declined).

    I used Keynote with a “older” (2007-ish?) projector  and modified settings to NOT mirror displays.

     

    I’m about to install the latest iTunes update – v. 11.1.4 – and I might try the 100% CPU fix version linked above – I’ll let you know if that changes anything.

    #64613
    casj
    Member

    Latest iTunes installed, both fixes installed (in the order given in this thread – first the whole package 24-bit test version, then replaced the application with the 100% CPU fix) – and so far pref pane/taskbar icon/volume issues seem resolved! Hooray! 🙂

    #64612
    xaqmusic
    Keymaster

    Yay!  Thanks for the detailed feedback.  I’m glad you found success with the 100% CPU hotfix.

    I’ve personally be experiencing plenty of odd issues with audio even without DPS running (pro audio applications) so my gut is telling me Mavericks is still in it’s maturing phase.  I seem to recall Mountain Lion getting through this phase much quicker!

    Anyhow, we finally got a reply from Apple’s driver team about getting to the bottom of the stuttering audio with video issues.  More answers for you fine folks soon…

    #64611
    pnickol
    Participant

    Will you notify us when the 1.0.5 version is available, or do we just have to keep checking back?

    thank you

    #64610
    xaqmusic
    Keymaster

    Ok, folks!

    We have a new update available for Mac – Click here to download Digital Power Station v1.0.5

    This version includes the fix for 100% CPU usage.  This may be the cause for some users getting lag in the volume control and a few other symptoms.  This version also allows for 24 or 32bit driver modes in Audio/MIDI settings for those of you connecting to home theatre gear.

    This still does not fix the stuttering audio while watching video in full screen mode with QuickimeX.  Apple has given us some information about new media driver measurement tools but they are not working correctly :-/   I’ll get you more info as we get it…

    #64609
    anthonyday
    Participant

    Wondering if any progress has been made here?

Viewing 15 posts - 16 through 30 (of 38 total)
  • You must be logged in to reply to this topic.