Bongiovi DPS

MAC-OS 10.14 Mojave Issues

Forums Bongiovi DPS 2.2 MAC-OS 10.14 Mojave Issues

Viewing 15 posts - 31 through 45 (of 79 total)
  • Author
    Posts
  • #84314
    M.O.H.
    Participant

    Hello Nuke
    Well, may be we will have some snow here in the central parts of Switzerland in the winter!

    I have news for you!
    My DPS is working again!
    I was thinking about how precisely I installed Boom 3D and remembered suddenly, that Boom 3D asked me the permission for the microphone in the security pref pane.
    So I installed immediately a new copy of DPS, installed and activated it (and yes, there will be a blue DPS icon in the menu bar, indicating that DPS is processing sound).
    I hadn’t a keychain request nor security hints. So I allowed manually DPS in the accessibility tab of the security pref pane and also the microphone in the microphone tab.
    With a little shiver I opened iTunes and voilà: There was sound!
    I hope this will help you, if it’s not the keychain issue you mentioned…

    BTW: Boom 3D is charged, like DPS

    Regards
    mo

    #84318
    xaqmusic
    Keymaster

    Thanks for the healthy discourse, nuke and mo. While these Mojave quirks are proving more annoying than previous upgrades of OSX, at least it this is not like Mavericks!

    Nuke,

    If Dan is reporting “it works”, he certainly means the blue icon is in the taskbar and audio is processing as expected. Dan handles most of our support tickets and is very thorough in his testing procedures. I totally understand if you want to wait for his confirmation but he won’t be back at work until Monday. I’d hate for you to have to suffer non-DPS iTunes all weekend 😉

    Since Mo, our testing group and a few other users have reported success, I think it is safe for you to try reinstalling 2.2.0.9. Be sure to click “Always Allow” if any keychain access is requested.

    I spoke with our lead developer for OSX and we are investigating alternative ways to store credentials securely to avoid this in the future.

    #84319
    nukefixer1
    Participant

    Hmmm,
    Well I did indeed take the leap off faith, installed 2.2.0.9 and it asked for my system password and I entered it and it said installed successfully, and guess what……

    No sound, no menu tray icon, so once again I using the installer uninstalled it, and using iTunes, within system preferences I have selected earphone and have sound again.

    I am wits end.

    It appears not matter what I try, no DPS plugin for me?

    regards,

    Nuke

    #84320
    nukefixer1
    Participant

    So after my leap of faith, I rebooted and sure enough, I had to re-enter all my internet mail passwords within preferences.

    So that’s me for now, until all the issues are worked out, I don’t plan to reinstall.

    regards,

    Nuke

    #84321
    M.O.H.
    Participant

    Sorry for the question Nuke, but have you ever restarted your Mac in this time?
    Sometimes it’s like magic…
    Or try SMC-Reset and PRAM-Reset or perhaps a safe boot.

    OOPS, to late…I was to slow with my answer.

    #84322
    nukefixer1
    Participant

    Mo,

    I’m done tinkering, I did a reboot, and then had to re-enter all my system internet mail passwords within Outlook again, so thats it for now.

    I appreciate your assistance, but I plan to wait some more.

    Regards

    Nuke

    #84323
    M.O.H.
    Participant

    It seems to me that you have a more fundamental issue with Mojave and the issues with DPS are only an aspect. (Keychain, Apple-ID, Passwords lost…)

    Regards
    Mo

    #84324
    Dan Rice
    Keymaster

    So having performed the installation of 2.2.0.9, is the “B” icon showing in the top right menu bar?
    And it’s now running correctly?
    Regards Nuke

    Dan,
    So having performed the installation of 2.2.0.9, is the “B” icon showing in the top right menu bar?
    And it’s now running correctly while using Mojave?
    Regards Nuke

    Hello Dan,
    Can you confirm that 2.2.0.9 reinstallation with Mojave that the DPS plugin is working and that blue “B” icon is showing in the menu bar?
    Regards Gary

    Yes, DPS is working fine for me on Mohave. This includes all the intended and expected behaviors, e.g. blue “B” icon, startup on login and audio processing.

    My delay in responding can be accounted for by understanding that the testing process is time consuming, e.g. setting up High Sierra machines, then updating them to Mohave with different permutations of DPS installed or not installed, etc.

    I have not yet been able to reproduce the issue that you are describing, but I am still trying to do so. Furthermore, we have not had any other reports of Keychain problems.

    Please let me know if you have any further questions for me, or feel free to respond through our support ticket system.

    Thank you,

    Dan R.
    DPS Support

    #84340
    Nick
    Participant

    Hi Everyone, I updated to Bongiovi 2.2.0.9, on Mojave 10.14. I first uninstalled the previous version, then installed the updated version, restarted iMac, but the app doesn’t work. It doesn’t show in the top right menu bar either.

    Any ideas on how to make this work?

    #84350
    Dan Rice
    Keymaster

    Nick,

    Please try starting the DPS application manually from Applications -> Bongiovi DPS folder. It should prompt you for some permissions (e.g. Use of the microphone.) After that, DPS should work normally.

    Please let us know the result of this.

    Thanks,

    Dan R.
    DPS Support

    #84351
    Nick
    Participant

    Hi Dan,

    I did try that approach as well, but didn’t work.

    I uninstalled Bongiovi again, reinstalled, but I never am prompted to provide permission to the mic.

    If permission isn’t granted to use the microphone, will this block the installation of Bongiovi? Reason I ask, I have SOPHOS (www.sophos.com) installed and there is a setting for microphone access but not sure if my app is blocking the permission set for Bongiovi.

    Thanks,
    Nick

    #84395
    LossLes
    Participant

    I still can’t get any version to work on my Mac Mini Mojave. Uninstalled but now my output is ‘stuck’ on DPSReflector and I have to go and change it to Digital Out.
    The Mac is in a cupboard and it is a pain to have to change it every time I switch the machine on.
    How can I ‘remove’ DPSReflector until a newer version comes out, please?
    Thanks

    Loss-Les

    #84396
    nukefixer1
    Participant

    Greetings sir,
    Have you tried uninstalling using the installer?
    When I had my Mojave issues, I utilized the installer to uninstall DPS and it took everything off.

    In the meantime, as suggested by Mo, I have purchased Boom 3D and it plays nicely with Mojave.
    I’m an avid music listener and couldn’t wait on the DPS issues to be resolved, I’ve tried installing and reinstalling and it even screws up my keychain and internet mail accounts, having me re-enter passwords.

    I feel your pain, but try using the installer to uninstall DPS, this is what is the preferred way of removing.
    If you have already done this, then I’m not sure what to do, I’ll leave that to someone more knowledgeable then I.

    Good luck.

    Nuke

    #84400
    Dan Rice
    Keymaster

    Loss-Les,

    Is DPS version 2.2.0.9 not opening at all for you, or is this a “No sound” issue?

    If you have no sound, please go to System Preferences -> Security and Privacy and click “Privacy”. On the left side, please select Microphone and confirm that the checkbox next to Bongiovi DPS is checked.

    As far as removing DPS from your system, you can use the uninstaller program found in the Applications -> Bongiovi DPS folder to uninstall DPS from your computer.

    Please feel free to open a support ticket if you wish. I look forward to your response.

    Thanks,

    Dan R.
    DPS Support

    #84454
    gmb
    Participant

    Hello,
    i completely reinstalled my iMac with Mojave, Bongiovi_DPS_Mac_2.2.0.9 cannot be installed, I don’t have a Bongiovi icon in the menu bar, error:

    Bongiovi DPS is installed but not currently available. Please try again or reboot if the problem persists, after restart the same result,

    Regards

Viewing 15 posts - 31 through 45 (of 79 total)
  • You must be logged in to reply to this topic.