Bongiovi DPS

Lag in Windows 8 x64

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #64493
    mark10000
    Participant

    I have used it on Cyberlink PowerDVD 13, and KM Player but I am getting lip sync problems.  It appears that the real time mastering is having an effect in the new version of Windows.

    I also use Adobe Audition CS6 for my business and it is disastrous because of the lag.  I now have to switch it off, exit the program and disable the program in the sound properties box.  It is a great program but it is a royal pain in the butt right now.

    I have also tried upping the resources to near real time but to no avail.

    #64506
    xaqmusic
    Keymaster

    Mark,

    We are aware of the issues with the DPS driver in Windows 8 and newer machines.  We are in the process of rebuilding the driver right now.  But in the meantime:

    When you quit DPS it should be switching back to your original output device automatically in Windows Sound Preferences.  Are you saying there is still lag even when DPS is not running and the Default Output Device is not set to (Speakers) Digital Power Station?

    Also, if you are using Adobe Audition or any other audio editing software, I recommend not using “Default Device” in the Audition audio setup window.  When you allow Windows to route the audio, there is a chance for lag or other unreliable results.  I recommend setting Audition’s outputs manually to connect directly to your output device of choice.  This will also prevent it from interacting with the DPS driver.

    Let me know how this works for you.

    #64505
    mark10000
    Participant

    I do not get the lag when I exit DPS.  I will exit the plugin prior to using Audition and see if that makes a difference.  If I just route Audition to my speakers whilst having the plugin going I still get the lag I believe, although I am now doubting that statement.  I’ll double check later and get back to you.

    Thank you.

    #64504
    Joseph Beaty
    Keymaster

    Thanks Mark! Definitely keep us posted with your findings.

    #64503
    rnadeau6299
    Participant

    I am using Sagetv ver 7.19 and am using the ac3 ver 2.6 decoder with windows 8 pro 64 bit and I don’t have any issues with playing music or movies. Everything is in sync. I realize this particular software setup  is not what is being talked about here but I thought I would put in my 2 cents worth. It may help the developers with debugging.

    #64502
    Joseph Beaty
    Keymaster

    Thanks rnadeau6299!

    #64501
    xaqmusic
    Keymaster

    I think sync issues arise with audio editors because they don’t attempt to sync with video or any other applications.  The main goal for an audio editor is to have quick response from the transport controls and accurate waveform display.  All latency for plugins are accounted for within the editor software.

    The DPS audio processor is expecting to get sync information from the application that is feeding it audio.  Usually this is your internet browser (Flash or Sliverlight), WMP or VLC media player which all supply frame sync info.  Commonly the latency is around 300ms for DPS (yeah, there’s a LOT going on under the hood) so the sync info is critical.  I’m certain Adobe Audition does not supply this info.

    #64500
    steveting99
    Member

    Using Windows 8 Pro with 64bit version.

    (1) I’m having issues with Foobar v1.2.9 selecting output device as KS:Digitial Power Station. It causes Foobar to have an error on the output. Only way around is to switch the output to DS: Speakers (Digital Power Station).

    (2) When I try to adjust the speaker properties for the high definition audio device under the advance settings, the default format cannot go above 2 channel, 24 bit, 48000 Hz. I have some high resolution recordings in 24bit/96kHz that I’d like to hear, but DPS crashes when this happens.

    Appreciate any help.

    #64499
    steveting99
    Member

    Hi guys,

    Just to report in further issues with Windows 8 64bit and Foobar2000 v1.2.9.

    (1) With KS output, doesn’t work at all and is broken. Suspect KS output only works with an external USB device as I got it working on the work PC + USB DAC and without DPS plug-in.

    (3) W<span style=”font-size: 13px; line-height: 19px;”>hile playing music, t</span><span style=”font-size: 13px; line-height: 19px;”>here’s an annoying pause/pop/click every time I start an application under Windows 8 64bit. Don’t know how to get rid of this. Sometimes this </span><span style=”font-size: 13px; line-height: 19px;”>annoying pause/pop/click</span><span style=”font-size: 13px; line-height: 19px;”> </span><span style=”font-size: 13px; line-height: 19px;”>happens when I switch between active applications. Using Chrome, Foobar2000 and iTunes (have the latest version) for tests.</span>

    Steve

    #64498
    xaqmusic
    Keymaster

    Thanks, Steve.  I haven’t used Foobar but I can see some issues from your description:

    Is it possible to choose “Default Playback Device” as an output in Foobar?  This would allow Windows to handle the routing and any sample rate conversion.  This way Digital Power Station will receive audio when it is running automatically.

    I also wonder if Foobar is trying to establish exclusive control over the Digital Power Station output driver and change its sample rate as if it were a standard speaker output.  The Digital Power Station is a virtual audio driver and behaves a little differently.  It’s main purpose is to act as a output in order to capture audio for the DPS software to process.  It’s intended use is as “Default Output Device”.

    Also, does your sound card support 96k sampling rates?  If not, then use 48kHz.  The down conversion is simple divide by 2 and may sound nicer than 44.1kHz.  Let us know your findings!

    #64497
    steveting99
    Member

    Hi xaqmusic,

    Something funny happened when typing in item (3) in my previous report. Let me type it again.

    (3) While playing music there’s an annoying pause/click/pop every time I start an application under Windows 8 64bit. Don’t know how to get rid of this. Sometimes this annoying pause/pop/click happens when I switch between active applications. Using Chrome, Foobar2000 and iTunes (have the latest version for tests.

    On Foobar2000, I’m now using the direct stream. Selecting either (a) primary sound driver or (b) speakers (Digital Power Station) works with DPS plug-in. The ‘B’ button works and there’s an impact to the sound.

    <span style=”font-size: 13px; line-height: 19px;”>When selecting direct stream using headphones (high definition output device) there is music coming out but the DPS plug-in doesn’t work. In this case selecting/de-selecting the ‘B’button has no impact to the sound. I believe Foobar2000 is bypassing the DPS plug-in. </span>

    I don’t have a sound card and using the built-in DAC on the motherboard. In this case it’s the Realtek ALC888 . It supports 192kHz sampling rate. The virtual driver for DPS plug-in is locked into 44.1kHz, maybe this is problem?

    Steve

    #64496
    xaqmusic
    Keymaster

    While playing music there’s an annoying pause/click/pop every time I start an application under Windows 8 64bit.

    This is a bit unusual though not unheard of.  These types of glitches in Windows 8 are why we are rebuilding the virtual audio driver.  Rebuilding and testing the audio driver is our main priority at the moment.  Parallel to that is brainstorming new DPS interface features for 2.0.

    On Foobar2000, I’m now using the direct stream. Selecting either (a) primary sound driver or (b) speakers (Digital Power Station) works with DPS plug-in. The ‘B’ button works and there’s an impact to the sound.

    Good.  Then it is working correctly.

    When selecting direct stream using headphones (high definition output device) there is music coming out but the DPS plug-in doesn’t work.

    That is correct and expected.  You want to always keep the direct stream for Foobar set to primary driver or Digital Power Station.  You should choose your Headphone output driver in the Output Device menu in DPS Preferences.

    Remember, DPS sits between the sound generating application (Foobar) and your listening device (headphones, speakers etc.).  This means you should control the audio using the DPS software.

    It supports 192kHz sampling rate. The virtual driver for DPS plug-in is locked into 44.1kHz, maybe this is problem?

    Most likely, yes.  However, when you play the higher sampling rate audio through Foobar set to primary driver with DPS running, does it work then?  I know 48k works though 96k or 192k require more to convert so there are issues.  We’ve always considered these sample rates to be “pro audio” and beyond the scope for DPS as a consumer product.

    However, we all know Blu Ray supports these higher sample rates and they are now considered to be part of the consumer media pool.  As we rebuild the DPS drivers we will be investigating feasibility of higher sampling rates.

    #64495
    steveting99
    Member

    Hi xaqmusic,

    When playing 24bit/96kHz FLAC files through direct streaming using either primary sound driver or speakers (Digital Power Station) the ‘B’ button does work.

    I also played pink noise to see if there’s any SPL difference between ‘B’ button and no-‘B’engaged. Surprised that the meter doesn’t recognize the sound difference that I’m currently hearing with my ears. Using C weighting average with a digital sound meter from Minolta.

    I haven’t tried higher sample rate music. Would need to purchase them and test it out.

    Steve

    #64494
    xaqmusic
    Keymaster

    When playing 24bit/96kHz FLAC files through direct streaming using either primary sound driver or speakers (Digital Power Station) the ‘B’ button does work.

    Great!  Then it is working properly.

    I also played pink noise to see if there’s any SPL difference between ‘B’ button and no-’B’engaged. Surprised that the meter doesn’t recognize the sound difference that I’m currently hearing with my ears. Using C weighting average with a digital sound meter from Minolta.

    Ah!  You’ve stumbled upon one of the really unique features of DPS!  You can’t use pink noise to measure with because it affects the dynamic range elements of the algorithm in ways that do not apply to music or movie content.  Remember, at any given moment in music there are varying amounts of each frequency.  This content is always changing over time.  Our ears work the same way… a phD friend of ours calls our ears “time history detectors”.  The are not level detectors or frequency analyzers.  Our ears recognize patterns.  That is only one of the reasons DPS sounds better and louder while measuring equally with simple weighted SPL meters.

    Another example of the effect on the wavform can be found in this explanation of DPS HEAR: http://bongiovimedical.com/technology/dps-hear/

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.