Bongiovi DPS

DPS 2.0 Testing (OSX)

Forums Bongiovi DPS 2.2 DPS 2.0 Testing (OSX)

Viewing 15 posts - 121 through 135 (of 135 total)
  • Author
    Posts
  • #64949
    Dan Rice
    Keymaster

    Smjonesin,

    Please try the following to solve this issue:

    1.) Quit DPS by clicking the DPS “B” icon in your top menu bar.
    2.) Pair your Bluetooth Device with your Mac.
    3.) Pause any audio that might be playing.
    4.) Restart DPS
    5.) Select the Bluetooth Device from the DPS Output Device menu.

    Please feel free to email me directly at drice@bmtdps.com if this does not solve the proble, or if you have any further questions.

    Thanks,

    Dan Rice
    DPS Support

    #64962
    Anonymous
    Inactive

    Hello,

    Been having an issue with bluetooth connectivity with the DPS Application for MacOS. This has been present in the older 1.X version(s) as well as the new 2.0 version. I will go through the steps of connecting my bluetooth device and if you could let me know if this is intended behaviour or a bug that would be great;

    1. Turn on my bluetooth speaker (JBL Charge)
    2. Turn on bluetooth on my Laptop (Mid-2012 MacBook Pro 13″, running macOS Sierra 10.12)
    3. My device auto-connects to my laptop
    4. To get the sound to go through the speaker and not “Build-in Output”, I have to go to the DPS menu icon > Output Device > and select my device. Great, now it connects
    5. I don’t want to use my MacBook Air profile for my external speaker, so I select “Listening To: Desktop Speakers”. At this point I would think it should be configured correctly and working, but after select Desktop Speakers, the Output Device has now switched back to “Build-in Output”
    6. I have to go back to Output Device and reselect the external device to get output to come through the external speaker and not my laptop

    Thanks for your input in advance,

    Randy B.

    #64965
    Dan Rice
    Keymaster

    Randy B.,

    From the DPS “B” icon drop down menu, if you select Listening To: Desktop Speakers first, then choose the output device you should have a better result.

    Also, in this case it might be easier if you work from the Bongiovi DPS Preferences -> Settings tab.

    The way we have the interface laid out, each “Listening To:” choice corresponds to a previously selected “Output Device”, but not vice versa.

    I’ll pass your experience on to my development team as feedback.

    Thanks,

    Dan Rice
    DPS Support

    #64966
    es0phagus
    Participant

    Hey, I think I found another slight irritant: it seems that when I wake my Macbook from the ‘display off’ phase while music is playing through DPS, there is always a slight split-second jump gap audible in the song playing. I think I have noticed this at other random times too, but I have not been able to reproduce so it any other way, so it appears most likely to be via this method.

    If you are unable to reproduce this, I could probably send a recording.

    #64969
    Dan Rice
    Keymaster

    es0phagus,

    I believe this is being caused by a CPU spike that occurs when you monitor comes back on, DPS is a pretty CPU intensive utility. Just to be sure though, can you tell me what programs you have running when this happens? Feel free to email me directly at drice@bmtdps.com or create a support ticket if you don’t want to post publicly.

    Yours,

    Dan Rice
    DPS Support

    #64970
    es0phagus
    Participant

    Nothing special: just typically Firefox, Microsoft Word, Adobe PDF Reader, and music playing app Swinsian are activate. There’s some background apps, such as Bartender, CleanMyMac, Flux, but they aren’t CPU intensive or anything.

    #64971
    es0phagus
    Participant

    When I quit DPS, the split-second gap doesn’t occur.

    #64974
    es0phagus
    Participant

    Okay, I have also discovered the cause of the other “random times” that I mentioned in my original post. It occurs when the screen is asleep but because the monitor briefly displays a notification (banner) when there is a track change. Obviously this is annoying and you basically cannot allow your monitor to sleep while playing music.

    #64975
    Dan Rice
    Keymaster

    es0phagus,

    I’m not able to reproduce a stutter on my system while the display is off and iTunes song change notifications are turned on. Have you tried turning off your iTunes song change notifications?

    You can do this by clicking the notifications area at the top right of your desktop, then selecting the settings gear icon down at the bottom right. Scroll down and select iTunes from the list and select the iTunes alert style “None”.

    Please let me know if this solves the problem.

    Thanks,

    Dan Rice
    DPS Support

    #64977
    Anonymous
    Inactive

    Hey Dan Rice,

    Thanks for that tip. By selecting Listening To: Desktop Speakers first, then the output device, all seems to be okay 🙂


    @es0phagus
    , Dan Rice

    I can also confirm the issue with iTunes skipping/stopping the audio for about a second. Just tried it out of curiosity, set my display sleep to 1 minutes, turned OFF iTunes notifications. Let the display sleep, but when clicking the trackpad to wake the display, the audio skipped/stopped for about a second. Same result using my MacBook Pro internal speakers and my external speaker.

    Thanks,

    Randy B.

    #64978
    es0phagus
    Participant

    Turning notifications off would probably solve the problem as it only occurs when the display briefly turns on to display the track change notification. But, to be honest, playing music without notifications is a big bummer… I like being able to instantly see what song is next without having to listen for the first 30 seconds or so trying to figure it out.

    It is a shame, I didn’t realise DPS was that big of a CPU hog. Is it possible that you are not able to reproduce it perhaps you have a better CPU that is, presumably, able to handle it better? My processor is: 2.7 GHz Intel Core i5

    Thanks.

    #65013
    es0phagus
    Participant

    Hey,

    This might seem like a silly question, but does DPS use the same amount of energy/cpu even when no audio is playing? I am trying to figure out whether it is worthwhile quitting the app completely in between use.

    #65018
    Dan Rice
    Keymaster

    Es0phagus,

    In our testing, with audio playing and the visualizer displayed, DPS used approximately .4 – .6% of the testing computer CPU. On Mac, the audio path must stay open for DPS to work. So there is some CPU use, even when Audio is not playing. However, it checks to see if audio is playing every few minutes. If audio is not playing it stops the stream so the computer can sleep.

    Hope this helps –

    Dan Rice
    DPS Support

    #65170
    MightyBoo
    Participant

    Hello,

    Previously i had issues with “cracking/ static” disturbance occasionally, when using DPS. Even with the latest version. I have isolated the issue, and fixed it.

    It has to do with (in my case, macbook pro mid 2010 2.66GHz) intel’s turbo boost. After loading a script into launchdaemons to disable intel’s turbo boost at every boot… no more noise disturbance… btw, my graphics card no longer throttles/lag too!

    On a side note, i have been using Encore mDSD DAC together DPS, and its great, except for 1 issue. Upon reboot, or boot up, DPS insider “headphones” section, output keeps defaulting to system output; i have to always manually select Encore mDSD as the output… would be great if DPS preferences can be saved with last known selection.

    Thank you for your great work!

    #65193
    xaqmusic
    Keymaster

    Bongiovi DPS 2.1 Preview has begun! Thread is here

Viewing 15 posts - 121 through 135 (of 135 total)
  • The topic ‘DPS 2.0 Testing (OSX)’ is closed to new replies.