Bongiovi DPS

Bongiovi DPS 2.2 – The Gaming Release

Forums Bongiovi DPS 2.2 Bongiovi DPS 2.2 – The Gaming Release

This topic contains 39 replies, has 12 voices, and was last updated by  xaqmusic 1 month ago.

Viewing 15 posts - 16 through 30 (of 40 total)
  • Author
    Posts
  • #83939

    bnmguy
    Participant

    Works great!
    As always, thanks for such a speedy fix, Joey!

    #83976

    LossLes
    Participant

    V# 2.2.0.9 doesn’t want to run on my mac Mini (late 2012) running Mojave (latest v#)

    #84088

    enkaytee
    Participant

    Not sure if it’s a bug, expected behaviour or a problem with my system, but on my Mac (High Sierra 10.13.6) DPS 2.2.0.8 seems to preventing the PC from sleeping. I’ve run ‘pmset -g assertions’ and I get this:
    BackgroundTask 1
    ApplePushServiceTask 0
    UserIsActive 1
    PreventUserIdleDisplaySleep 1
    PreventSystemSleep 0
    ExternalMedia 1
    PreventUserIdleSystemSleep 1
    NetworkClientActive 0

    The details referring to ‘PreventUserIdleSystemSleep’ are:

    pid 196(coreaudiod): [0x0002480d000199c9] 00:00:10 PreventUserIdleSystemSleep named: “com.apple.audio.AppleHDAEngineOutput:1B,0,1,2:0.context.preventuseridlesleep”
    Created for PID: 42489.
    pid 196(coreaudiod): [0x0002480d000199c1] 00:00:10 PreventUserIdleSystemSleep named: “com.apple.audio.DPSReflectorEngine:0.context.preventuseridlesleep”
    Created for PID: 42489.
    pid 196(coreaudiod): [0x000245dc000199ac] 00:09:31 PreventUserIdleSystemSleep named: “com.apple.audio.AppleHDAEngineOutput:1B,0,1,2:0.context.preventuseridlesleep”
    Created for PID: 42481.

    If I quit DPS, then the Mac sleeps according to the power saving settings.

    Any thoughts?

    #84089

    xaqmusic
    Keymaster

    LossLes,

    Let me know if you had any success with 2.2.0.9. Our tests show it working well in Mojave. Please send console output if it is crashing.

    enkaytee,

    Bongiovi DPS will prevent sleep while the audio stream is open. This is necessary to capture every sound from all applications at the moment those sounds are generated. To get around the sleep issue, Bongiovi DPS will look for silence in the audio stream. You will see these messages in the console. If silence is detected for 5 minutes the stream will stop so sleep is allowed. At that point, your normal sleep timer will kick in and your Mac should sleep as usual. Let me know if you do not see that behavior.

    #84176

    rejzor
    Participant

    Sorry but subscription model is absurd given how little updates you guys make to the app. Paying 30€ a year for nearly no updates to the app is just absurd quite frankly. It took over a year and a half for update from 2.1 to 2.2. And I bet they fixed none of the stupid volume problems I’ve been having where volume levels are all screwed up when you boot the system up, nearly giving me a heart attack when Windows does “doink” sound at 3 in the morning at full volume on powerful speakers…

    #84177

    rejzor
    Participant

    And yup, you haven’t fixed ANYTHING. Rebooted system and volume of Bongiovi was at 75% even though it was at 30% when I rebooted the system. With soundcard volume at 100% (so I can at least get any kind of decent volume out of the system and fully control volume through keyboard volume buttons), this means I’m gonna kill someone at night for turning on a PC. Get your shit together before you try charging money for your broken app. This is the reason why I haven’t bought it before (v2.1) and it’ll remain a reason why I’m not buying it now either at v2.2… How the hell app doesn’t remember last set volume level and just stubbornly insists on 75% is just absurd.

    #84178

    rejzor
    Participant

    Oh god, not only that, it also turns parent soundcard volume to 10% every time. Who designed this idiocy? Useless.

    #84179

    xaqmusic
    Keymaster

    Thanks for taking the time to share, rejor. You have hit upon an issue that had dogged us for almost a decade now; Windows audio driver volume handling.

    UPDATE: To address your issue at the top of this very long post, please try this:
    Un-check AUTO ADJUST VOLUME

    Regarding the subscription and price and such, this was a necessary step for us to move the Bongiovi DPS app forward. You may not see it on the surface, but the audio processing changes under the hood between 2.1 and 2.2 are significant. I’m happy to discuss V3D, the new Virtual Subwoofer algorithm, and the myriad of gaming-centric profiles.

    Back to Windows volume control. We describe the audio system like this:.
    Windows drviers and audio path.

    On Mac computers, I think we achieved a nice level of “it just works”. This is due to the consistent nature of all Mac computers and the sensible way their Core Audio engine works. In Windows, its a lot different.

    On a Windows computer, the output driver that is set to Default Playback device receives the volume control messages from the keyboard. As you can see in the diagram, the Digital Power Station driver must be the default device so we may process the audio and send it out to the hardware device (laptop speakers, USB headphones, HDMI etc). So what do we do when DPS is launched and the hardware driver is set to some low level? If we just leave that driver’s volume as-is, that driver (let’s say it’s your laptop speakers) will be “stuck” there without keyboard volume level control. No matter how much you turn up the volume (affecting the DPS driver only) the volume will be limited to that set previously for your laptop speakers. On a laptop that’s a big problem since they are already really quiet!

    To overcome this we set the output device to 75% and bring the previous volume level of that output over to the Digital Power Station driver. This works well enough for most folks but we are now seeing a trend of Windows 10 computer manufacturers making “smart” audio systems that try to manage the audio devices for you. Also, we have to contend with several different audio chip manufacturers that (unlike Apple) do not publish their system messages for when a device (like plugging in headphones) is connected or disconnected.

    That is why we added a checkbox in the SETTINGS tab for disabling automatic volume adjustment. Read about it here.

    I hope that turning off this feature-for-some-annoyance-for-others will make your audio experience better with Bongiovi DPS! Please contact Joe or Dan by making a support ticket and they will take care of you.

    We are totally open to suggestions regarding the Windows volume issue! We understand there is no one-size-fits-all solution that is not overly complex. I have had these ideas in mind:

    1 – Take a system settings snapshot: This would save all of the volume levels for all of the drivers. You could set this snapshot to be recalled whenever the app launches or when you switch to different output modes.

    3 – Provide a specialized DPS volume control: We could provide volume sliders on the GUI for each hardware device so you could easily set and recall the volume level. The downside is a more cluttered SETTINGS tab that deviates from the Mac version.

    4 – INI file: For the power users out there, an editable initialization file could override any default behavior so all volume levels at startup are explicitly set.

    5 – A combination of all of the above?

    Let me know what you think!

    #84188

    rejzor
    Participant

    The Auto Adjust volume does nothing at all. On every boot, Bongovi has 75% volume and host audio 10%. I don’t get it why is there even a need for this. Even if I manually set host audio volume and then use keyboard volume controls for current audio (Bongovi), as soon as I reboot the system all goers to s**t because ot’s again reset to 75% and 10%. Why, I have no clue if I manually adjusted it before. It’s stupid.

    #84195

    hans
    Participant

    As far as I understand DPS only saves the volume when it’s exited while the currently active soundcard is not DPS. In this case the DPS volume is set to the highest value of either the current DPS volume or the currently active soundcard volume but at most 75%.

    So you could e.g. do this:

    1. Set DPS volume to 50% or lower. Quit the DPS software completely. (Do not just press the B button, actually exit DPS!)
    2. Set the volume of your actual soundcard to 50%. Dot not switch to any other volume control. Your actual soundcard needs to stay the currently active one!
    3. Reboot. Both DPS and your actual soundcard should now be set to 50% volume.

    At least that’s how it works for me.

    #84196

    rejzor
    Participant

    Why would it even reset ANY of it? It’s clearly Bongiovi doing it because without it, volume levels remain where I set them manually. But with Bongiovi, it’s a stupid resetfest.

    #84253

    xaqmusic
    Keymaster

    Hey guys,

    We went back over the logic for the volume control adjustments. As I mentioned in the earlier post this has evolved over time to provide “it just works” functionality for the widest range of users. In the current version, the only time we truly do not touch the volume levels is when the user is using headphones. The speaker modes, as rejzor has so kindly pointed out, are still a resetfest.

    We agree that when “Auto-adjust volume” is unchecked, the expected behavior should truly be “don’t touch any of my @#&! volume levels!”.

    Click here to download Bongiovi DPS 2.2.0.16. When auto-adjust is checked, everything is the same as last version. When unchecked, no levells are adjusted. Let us know what you think!

    #84268

    David
    Participant

    Is my configuration too old to run the latest MacOS version of Bongiovi? I have a 2011 MacBook Pro running High Sierra. (I can’t update to Mojave.) This evening Bongiovi popped up a message that a I needed to install a required update. That was followed by a series of keychain errors and it stopped running. I tried uninstalling, and then downloading and installing a fresh copy. No keychain errors, but the app does nothing when it launches. Thanks.

    #84269

    David
    Participant

    I got it to launch by restarting. Only now my license is no longer valid. Oh well.

    #84271

    xaqmusic
    Keymaster

    David,

    We are addressing Mojave issues in this forum topic. See you over there for the discussion…

Viewing 15 posts - 16 through 30 (of 40 total)

You must be logged in to reply to this topic.