Bongiovi DPS

Reply To: Mavericks OSX Issue List

#64632
xaqmusic
Keymaster

Hi, everyone.  As you all know, we’ve been running extensive tests with DPS and OSX Mavericks.  Here are the results from our programmer (testing audio glitch issue when playing video):

I used QuickTime for all of these tests.
1. If I run the DPS app with the engine turned off, the problem still occurs (~9:30into playback).
2. When re-synching, I attempted tearing down and rebuilding the RingBuffer. The problem still occurs (~9:30into playback).
3. With the DPSReflector still selected, I tried running Apple’s CAPlayThrough utility instead of the DPS app. The audio problem actually occurs sooner (~8:30into playback).
4. I installed the latest SoundFlower kext. I then selected the SoundFlower (2ch) virtual driver and ran the CAPlayThrough utility. The problem still occurs (~10:00into playback).
5. I selected the SoundFlower (64ch) virtual driver and ran the CAPlayThrough utility. The problem occurred immediately.
We can eliminate the DPS processing algorithm or the RingBuffer as a source of the problem.
I’m convinced that it’s an OS X 10.9 problem. The tentative 10.9.1 release target is end of November.
This is pointing us toward OSX issues that are currently beyond our control.
We have created a new build for you to try if you are interested in tinkering and testing yourself: Download DPS TEST1
  • This is just the application part of DPS.
  • You must have already installed and activated DPS v1.0.4 for this to work.
  • You may drag it into the Digital Power Station folder in Applications.
  • This version was built using the latest Xcode.
  • It is possible to change the Ring Buffer size in the Info.plist file in this test app.  Default is 20480.  The new value takes effect when the app is restarted.  Contact me if you want details on this.

We will continue to test and evaluate DPS in Mavericks.  Due to the sensitive nature of having a system level application, these issues are more complex and hidden by Apple than your usual player or other app that does not contain a kernel extension.

Thanks for your patience everyone.  And keep those issues rolling in!